Xampp Server Error - Apache is not starting

If you don't find any appropriate forum thread to post your question, then post on this thread by creating a new topic.
Daisy Watson
Junior Member
Posts: 6
Joined: Sat Jul 23, 2016 3:23 pm

Xampp Server Error - Apache is not starting

Postby Daisy Watson » Wed Jul 27, 2016 9:07 am

Dear all,

I am new to tech stuff. I have installed Xampp on my windows PC, and started the service mysql but Apache is not getting started. And, so I cannot access local host on my browser. Please Help.

Atish Ranjan
Administrator
Posts: 288
Joined: Sat Jul 23, 2016 12:12 pm
Location: India
Contact:

Re: Xampp Server Error - Apache is not starting

Postby Atish Ranjan » Wed Jul 27, 2016 9:24 am

Daisy Watson wrote:Dear all,

I am new to tech stuff. I have installed Xampp on my windows PC, and started the service mysql but Apache is not getting started. And, so I cannot access local host on my browser. Please Help.


Hi Daisy,

Good question.

Apache is not getting started because Port 80 might be busy.

If skype is running on your computer, Go to Tools => Options => Advanced => Connections

Untick Use port 80 and 443 for alternatives for incoming connections this and save.

Now close the Skype.

Try to start Apache again.

It should work!

But, if it still doesn't get started. Then do as below mentioned:

Open the interface of XAMPP, and look for "config" next to Apache

apache.png
apache.png (32.6 KiB) Viewed 764 times

Click on Config, and select Apache (httpd.conf)

In the file, look for

Listen 80

Replace it with

Listen 8080

Now try to find,

ServerName localhost:80

and replace it with

ServerName localhost:8080

Save the file!

Now, open Apache (httpd-ssl.conf) file from the same way.

Now,

replace Listen 443 with Listen 4433

Replace

<VirtualHost _default_:443>

ServerName localhost:443


With

<VirtualHost _default_:4433>

ServerName localhost:4433


Try restarting the Apache Service, and it must start running.

Now you can access localhost in the browser but remember one thing that since we replaced Listen 80 to listen 8080, you have to locate Localhost in the browser as localhost:8080.
Atish Ranjan
Administrator

Daisy Watson
Junior Member
Posts: 6
Joined: Sat Jul 23, 2016 3:23 pm

Re: Xampp Server Error - Apache is not starting

Postby Daisy Watson » Wed Jul 27, 2016 11:42 am

Wow!

Worked well. Thank you. Now Apache is running. I can access localhost in my browser too.

Thank you so much.


Return to “Miscellaneous”

Who is online

Users browsing this forum: No registered users and 1 guest